Important WordPress security alert

Thursday, September 25, 2014


If you are using the WordPress MailPoet plugin and you have not updated it since before the1st of July it is important you do so. A vulnerability has been discovered that allows hackers to attack websites and send spam email. This is a growing problem and to ensure the safety of all our customers we will have to start suspending vulnerable websites.






RSS View RSS Feed